Excel (L7): arrotondare per difetto ed eccesso, euro

In taluni casi si rende necessario arrotondare una cifra, soprattutto quando si parla di euro e quindi di soldi, per eccesso, per difetto a numeri interi o al primo decimale.

loading...

La regola automatica per arrotondare un numero è la seguente, in caso di intero (quindi nessun decimale).

Se la cifra compresa:

  • Da .01 a .49 centesimi (<50; inferiore a .50) si arrotonda per difetto.
  • Da .50 a .99 centesimi (>=50; maggiore o uguale a 50) si arrotonda per eccesso.

Esempio:

€ 1.44 diventa € 1.00

Mentre € 1.52 diventa € 2.00

——

arrotondamento-excel

Se invece si desidera visualizzare la prima cifra decimale, si arrotonda per decine di centesimi.

Se la cifra inclusa è:

  • Da .01 a .04 centesimi (<5; inferiore a 0.5) si arrotonda per difetto.
  • Da .05 a .09 centesimi (>=5 maggiore o uguale a 5) si arrotonda per eccesso.

Esempio:

€ 1.44 diventa € 1.40

Diversamente € 1.46 diventa € 1.50

—-

Formula Excel:

(Matematiche e Trigonometiche)

In tutti i casi in esempio, due sono i valori da tenere in considerazione, il numero o la cella che contiene la cifra da arrotondare e il numero di cifre che si desidera arrotondare (zero per numero intero; uno arrotonda alla prima decina dei centesimi).

Arrotondamento automatico per difetto o per eccesso, a valore intero o alla prima cifra decimale.

=ARROTONDA(A1;0)

Arrotonda la cifra presente nella cella A1 per numero intero, escludendo le cifre dopo la virgola.

Esempio: A1 = 1,44 arrotonda per difetto è diventa numero intero 1

A1 = 1,52 arrotonda automaticamente per eccesso è diventa numero intero 2.

Come nella regola spiegata sopra.

=ARROTONDA(A1;1)

Questa volta arrotonda alla prima decina dei centesimi.

Esempio: A1 = 1,44 arrotonda per difetto è diventa numero 1,4

A1 = 1,46 arrotonda automaticamente per eccesso è diventa numero 1,5

Come nella regola spiegata sopra.

—-

Arrotondamento automatico sempre per difetto.

=ARROTONDA.PER.DIF(A7;0)

Arrotonda in ogni caso per difetto a cifra intera.

Esempio: A1 = 1,44 arrotonda per difetto è diventa numero intero 1

A1 = 1,99 arrotonda per difetto ed è 1.

=ARROTONDA.PER.DIF(A7;1)

In questo caso l’arrotondamento è sempre per difetto ma mostra il primo decimale.

Esempio: A1 = 1,44 arrotonda per difetto è diventa numero intero 1,4

A1 = 1,99 arrotonda per difetto ed è 1,9

Arrotondamento automatico sempre per eccesso, a partire da 0.1

=ARROTONDA.PER.ECC(A8;0)

Esempio: A1 = 1,44 arrotonda per eccesso è diventa numero intero 2

A1 = 1,01 arrotonda per difetto ed è 2.

=ARROTONDA.PER.ECC(A8;1)

In questa circostanza l’arrotondamento riguarda non il numero intero ma la prima cifra decimale, se compresa tra 0.01 e 0.09

Esempio: A1 = 1,44 arrotonda per eccesso è diventa numero 1,5

A1 = 1,99 arrotonda per eccesso ed è 1,9

—-

Troncamento

Elimina tutte o alcune cifre presenti dopo la virgola.

=TRONCA(A1;0)

Impostando 0 il numero diventa intero (e come se venisse arrotondato per difetto indipendentemente dal valore).

Con uno, mostra il primo numero dopo la virgola (anche qui arrotondamento per difetto alla prima decina).

Con due, mostra i centesimi ed esclude eventuali millesimi.

Arrotondamento a multiplo

Cifre intere.

Due i valori da impostare: numero e peso, quest’ultimo è il multiplo con il quale si vuole arrotondare il numero.

=ARROTONDA.MULTIPLO(A1;5)

Arrotonda automaticamente per difetto (cifra compresa tra 0 e 4) o per eccesso (maggiore di 5) in base al multiplo impostato.

A1 =4 -> restituisce 5
A1 = 7 -> restituisce 5
A1 = 14 -> restituisce 15

Arrotonda per numero intero (difetto) considerando il multiplo più vicino. E’ utile qualora si desidera che la cifra sia un numero che finisca con zero oppure con cinque.

=ARROTONDA.DIFETTO(A1;5)

A1 =4 -> restituisce 0
A1 = 7 -> restituisce 5
A1 = 14 -> restituisce 10

=ARROTONDA.DIFETTO(A1;10)

A1 =4 -> restituisce 0
A1 = 7 -> restituisce 0
A1 = 16 -> restituisce 10

Lo stesso vale però per eccesso.

=ARROTONDA.ECCESSO(A1;5)

A1 =4 -> restituisce 5
A1 = 7 -> restituisce 10
A1 = 14 -> restituisce 15

=ARROTONDA.ECCESSO(A1;10)

A1 =4 -> restituisce 10
A1 = 7 -> restituisce 10
A1 = 16 -> restituisce 20

Arrotondamento a 0,50

=ARROTONDA.MULTIPLO(A1;0,5)

Se la cifra è compresa tra 0,25 e 0,74 viene arrotondata sempre a 0,50; diversamente viene arrotondata per intero per eccesso o difetto.

[wpdm_file id=11 title=”true” ]

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *