Excel (L4): Foglio di calcolo con la funzione Se (nidificata)

La funzione logica SE di Excel consente di verificare che una determinata condizione abbia risultato VERO o FALSO.

La sintassi è la seguente

=SE(C1=A1+B1; “Ok”; “Errore”);

Dove C1=A1+B1 è la formula da controllare e i due successivi dati sono i risultati prima vero e poi falso.

Funzione SE nidificata

La funzione SE può essere nidificata, ovvero inserire altre condizioni se in un’unica formula, fino ad un 64 anziché le 7 delle versioni antecedenti al 2007 di Excel.

Esempio:

Associare automaticamente alla frequenza televisiva il canale predefinito dal sistema europeo di trasmissione digitale terrestre.
Poiché il software dvb-t è in grado di gestire tali dati solo per frequenza in MHz e non per il corrispettivo canale, ecco un modo pratico di usare la funzione Se nidificata.
La frequenza 522000 MHz corrisponde al canale 26 della banda uhf.

Da notare che in questo caso non è stato utilizzato il valore falso.

 =SE(B2=191500;”7″;SE(B2=205500;”9″;SE(B2=474000;”21″;SE(B2=482000;”22″;SE(B2=490000;”23″;SE(B2=514000;”26″;SE(B2=522000;”27″;SE(B2=530000;”28″;SE(B2=538000;”29″;SE(B2=546000;”30″;SE(B2=554000;”31″;SE(B2=570000;”33″;SE(B2=578000;”34″;SE(B2=594000;”36″;SE(B2=618000;”39″;SE(B2=626000;”40″;SE(B2=634000;”41″;SE(B2=642000;”42″;SE(B2=65000;”43″;SE(B2=658000;”44″;SE(B2=666000;”45″;SE(B2=674000;”46″;SE(B2=682000;”47″;SE(B2=690000;”48″;SE(B2=698000;”49″;SE(B2=706000;”50″;SE(B2=714000;”51″;SE(B2=722000;”52″;SE(B2=730000;”53″;SE(B2=754000;”56″;SE(B2=762000;”57″;SE(B2=778000;”59″;SE(B2=786000;”60″)))))))))))))))))))))))))))))))))

Le formule come al solito possono essere scritte manualmente oppure utilizzando la procedura guidata di Office, prima selezionare la cella dove si vuole far mostrare il risultato poi facendo clic sulla scheda Formule e poi, in questo specifico caso, da Logiche, selezionare SE: nel primo caso inserire il valore o l’espressione da verificare e nei due successivi campi indicare il risultato in caso essa risulti vera o falsa e clic su ok.

loading...

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *