Statistiche web Geometria Excel con 3 punti cartesiani | Computer e Web

Geometria Excel con 3 punti cartesiani

Prendendo ad esempio un tipico esempio di geometria con tre punti cartesiani proviamo a risolverlo utilizzando il foglio di calcolo fornito da Excel. Sarà un insieme di funzioni e calcoli con riferimenti relativi. Step by step.

Calcolare l’equazione della retta r passante per A e B su Excel

La pendenza e l’intercetta su Excel si possono calcolare tramite funzioni specifiche oppure effettuando dei calcoli manuali potendo così verificare passo-passo tutti i passaggi.

La sintassi della funzione pendenza è la seguente:

=PENDENZA(A:A;B:B)

dove A:A sono le celle che contengono i valori delle coordinate y e B:B contengono i valori delle coordinate x.

Mentre la sintassi della funzione intercetta è:

=INTERCETTA(A:A;B:B)

Identica a pendenza cambia solo il nome della funzione.

Calcolare il coefficiente angolare applicando la formula

=(y2-x1)/(x2-x1)

Scrivere nelle singole celle B2 e C2 i valori delle coordinate del punto A e nelle celle B3 e C3 le coordinate del punto B; nella cella B5 scrivere la formula =b3-b2 e nella cella C5 digitare la formula =c3-c2; infine nella cella E5 formattata come frazione digitare

=b5/c5.

Calcolare l’intercetta con la formula

y=mx+q

Riprendendo l’esempio dovremo sostituire y e x con i punti delle coordinate A. Di conseguenza la formula da applicare sarà

=-(+e5)*c2+b2.

Il punto C appartiene alla retta r

Formula da applicare:

y0=m*X0+q

M rappresenta il coefficiente angolare mentre Q l’intercetta pertanto dovremo verificare se il valore del Y0 è uguale al prodotto di m con il valore di X0 e infine sommato all’intercetta q.

È evidente che trattandosi di una verifica utilizzeremo la funzione logica SE, infatti il sistema dovrà rispondere se è Vero quindi appartiene oppure Falso non appartiene.

=SE(=SE(C4=E5*B4+F5; “VERO”; “FALSO”)

L’equazione della retta s passante per C e parallela ad r

Formula da applicare:

(y-y0)=m(x-x0)

Su Excel potremo scrivere:

*e5(x-(+b4)-(+c4)

L’equazione della retta t passante per C e parallela ad r

(y-y0)=m1(x-x0)

Dove m1 è l’opposto reciproco di m pertanto in una cella a scelta, tipo E6 scriveremo la cifra reciproca opposta.

y=m1(x-(+x0))+(-y0)

=E6(X-(+c4))+(-b4)

Piano Cartesiano

Ottenuti i valori potete costruire le rette usando Excel oppure tool online come Geogebra.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *